Archive for the ‘MG’ Category

1954 MG Midget TF engine problems   1 comment

1954 MG TF on the lift for service at Autobahn Performance Inc. in Ft. Lauderdale Florida
 
 
 
 
 
 
 
 
 
   
We have a great customer who brought his MG TF in for an oil service. We and the customer observed that the engine was not running perfectly. The engine had very little operating time on it as the vehicle was just restored (although the restoration took approximately 8 years and the engine was the fist thing done). We assumed it was just going to need a new set of spark plugs and some basic adjustments. While replacing the spark plugs we noticed a considerable amount of oil in the # 2 cylinder. We did a compression test and found the compression to be low. We then did a cylinder leakdown test to find the percentage of leakage and to pinpoint whether it was a piston ring / cylinder wall problem or if it was a valve / valve guide problem. I was surprised to see water splash from the radiator cap when we tried to do the cylinder leakage test. The engine had a definite leak between the cooling system and the combustion chamber on cylinders 2 and 3.
 
The cylinder head would need to be removed to diagnose the leak, but we also still had the oil consumption problem; hopefully they were related. The customer gave us the go-ahead and we removed the cylinder head. "Now where did I put those old Whitworth wrenches?" We got the head off and were surprised to find it was from a 1250cc motor not the 1500cc that this vehicle was supposed to have. It had banana shaped coolant passages and was supposed to have round ones. The banana shaped passages were also corroded right up to the fire ring of the head gasket. This is where the coolant problem was coming from. Also the cylinder head gasket appeared to have been installed dry. (We usually apply two light coats of spray Permatex High Tack to help with sealing.)
 
The block was the correct 1500cc and was bored .060" oversize. The pistons still looked new but the cylinder wall finish was shiny and chattered looking. After considerable searching we and the owner of the vehicle located the correct cylinder head and had it rebuilt. We reinstalled the cylinder head on the motor and tried running it. The motor ran great at first but then began to misfire on cylinder 2 again. David "Gus" Taylor pulled the spark plug out and it was covered with oil. We weren’t surprised but were hoping that the valve guides were the cause of the oil consumption. We didn’t disassemble the old cylinder head, as we knew the new one would be in rebuilt condition. We had checked the piston rings by adding some mineral spirits to each cylinder and it held for a decent amount of time without flowing right past the piston rings. Any one of the rings can seal the fluid from flowing down the cylinder walls but it takes all three rings to keep the compression in the chamber and excess oil off of the cylinder walls.
 
We were going to have to remove the engine and disassemble it to examine the piston rings and piston to cylinder wall clearance. We explained this to the customer and had already warned him that the engine could also have a bottom end oiling problem. We got the go-ahead to pull the motor and inspect it. Here are some of the pictures of the car and the engine up to this point. We should know in the next day or two why the engine was burning oil.
 
 
 
 
 
 
 
At Autobahn Performance we take every precaution not to mark or scratch a vehicle. It should leave cleaner and in better condition than when it arrived.
 
 
 
Notice the oil on the tops of the pistons and tape, along with lots of care on the fender lip to protect the paint from chips
 
 
 
Advertisements

Posted March 12, 2009 by jayauto in MG